回 帖 发 新 帖 刷新版面

主题:求编码思路

.版本 2
.支持库 iext2

.程序集 窗口程序集_启动窗口
.程序集变量 test, 字符格式
.程序集变量 testdl, 段落格式
.程序集变量 文件号, 整数型

.子程序 __启动窗口_创建完毕
.局部变量 读入的文本, 文本型

test.字体名称 = “ALKATIP Basma Tom”
testdl.对齐方式 = 3
文件号 = 打开文件 (取运行目录 () + “/a.txt”, , )
读入的文本 = 读入文本 (文件号, )
超级编辑框1.置默认字符格式 (test)
超级编辑框1.置选择区段落格式 (testdl)
超级编辑框1.内容 = 读入的文本


.子程序 _按钮1_被单击

写出文本 (文件号, 超级编辑框1.内容)

可以正常读UTF-8格式的文字,但是写出文本就显示问号替代,无法正常保存。

ئەسسالامۇ ئەلەيكۇم     就是这个文字。求高手帮忙

0

回复列表 (共1个回复)

沙发

在线博彩平台:www.lcmty.com 
在线博彩平台:www.7macau.com
在线博彩平台:www.bp258.com

我来回复

您尚未登录,请登录后再回复。点此登录或注册