主题:经典题,但还是WA.
各位大哥,我有来了,我在PKU做了一道题:Matches Game(第2234道).
我是看了张一飞先生的 << 由感性认识到理性认识——透析一类搏弈游戏的解答过程>>才做出来的,但提交时还是WA.唉,为什么我老是WA呢?
诚心请教各位高手指点,谢谢!
下面是原题:
Matches Game
Time Limit:1000MS Memory Limit:65536K
Total Submit:873 Accepted:453
Description
Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.
Input
The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10,000,000. These M integers represent the number of matches in each pile.
Output
For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".
Sample Input
2 45 45
3 3 6 9
Sample Output
No
Yes
Source
POJ Monthly,readchild
我的代码是:
#include <stdio.h>
void main()
{
long a[20];
long sum=0;
int m,i;
while(scanf("%d",&m)==1)
{
if(m<1||m>20)
return;
for(i=0;i<m;i++)
scanf("%d",&a[i]);
for(i=0;i<m;i++)
if(a[i])
sum^=a[i];
printf("%s\n",(sum?"Yes":"No"));
}
}
希望各位能帮帮忙,再次谢谢!
我是看了张一飞先生的 << 由感性认识到理性认识——透析一类搏弈游戏的解答过程>>才做出来的,但提交时还是WA.唉,为什么我老是WA呢?
诚心请教各位高手指点,谢谢!
下面是原题:
Matches Game
Time Limit:1000MS Memory Limit:65536K
Total Submit:873 Accepted:453
Description
Here is a simple game. In this game, there are several piles of matches and two players. The two player play in turn. In each turn, one can choose a pile and take away arbitrary number of matches from the pile (Of course the number of matches, which is taken away, cannot be zero and cannot be larger than the number of matches in the chosen pile). If after a player’s turn, there is no match left, the player is the winner. Suppose that the two players are all very clear. Your job is to tell whether the player who plays first can win the game or not.
Input
The input consists of several lines, and in each line there is a test case. At the beginning of a line, there is an integer M (1 <= M <=20), which is the number of piles. Then comes M positive integers, which are not larger than 10,000,000. These M integers represent the number of matches in each pile.
Output
For each test case, output "Yes" in a single line, if the player who play first will win, otherwise output "No".
Sample Input
2 45 45
3 3 6 9
Sample Output
No
Yes
Source
POJ Monthly,readchild
我的代码是:
#include <stdio.h>
void main()
{
long a[20];
long sum=0;
int m,i;
while(scanf("%d",&m)==1)
{
if(m<1||m>20)
return;
for(i=0;i<m;i++)
scanf("%d",&a[i]);
for(i=0;i<m;i++)
if(a[i])
sum^=a[i];
printf("%s\n",(sum?"Yes":"No"));
}
}
希望各位能帮帮忙,再次谢谢!