回 帖 发 新 帖 刷新版面

主题:[讨论]求帮忙,谢谢、、、

题目描述

在CCTV2中有一档超市大赢家的节目,两个嘉宾竞猜商品的价格,看谁出的价格离商品的真实价格最近,商品就归谁所有,根据输入的价格判断谁是最后赢家,如果第个嘉宾离商品真实价格最近将系统认为the first sucess,注意:单词之间有一个空格。如果第个嘉宾离商品真实价格最近将系统认为the second sucess,注意:单词之间有一个空格。如果两个嘉宾竞猜的价格离商品价格一样近,则系统认为the first equal the second,注意:单词之间有一个空格。 所有变量都定义float型。 

输入

输入商品真实价格到一个变量中,然后回车。再输入两个嘉宾的竞猜价格到两个变量中,(注意:输入时以1个空格分开)并回车。注意:在样例输入里有三组数据分别对应样例输出里的三组数据。

输出

输出有以下三种可能之一:(1)the first sucess (2)the second sucess (3)the first equal the second

样例输入

98.23
78.5 102.45
78.25
80.54 156.98
67.9 
66.9 68.9

样例输出

the second sucess
the first sucess
the first equal the second

回复列表 (共1个回复)

沙发

#include <stdio.h>
#include <math.h>
static char *s[]={
   "the first success",
   "the second sucess",
   "the first equal the second" 
};
int main(int argc, char *argv[])
{
    float goods_price;
    float fir_price,sec_price,dif1_price,dif2_price;//dif为输入价格和货物价格的差价
    int flag;
    while(1)
    {
       flag=2;                              //默认两位判断的价格差距相等    
       puts("输入商品的价格(输入字符退出):");    
       if(scanf("%f",&goods_price)==1)
       {
          scanf("%f %f",&fir_price,&sec_price);
          dif1_price=fabs(goods_price-fir_price);
          dif2_price=fabs(goods_price-sec_price);
          if(dif1_price!=dif2_price)
          {
               flag=dif1_price<dif2_price?0:1;        
          }
          puts(s[flag]);
       } 
       else
       {
          break;
       }
    }
    return 0;
}

这段代码很不严格,具体细节需要修改的lz自己动手吧,这只是一个思路吧

我来回复

您尚未登录,请登录后再回复。点此登录或注册